26 comments on “Install the Latest Version of digiKam on Ubuntu 10.04

  1. amazing! I have been waiting for a ppa with recent digikam versions for ages! Thanks a lot!

  2. 4:4.5.0+svn1136700-lucid~ppa1 versioning is wrong. It should be 4:4.4.85+svn… – As you have it, that package has a higher version number than the final 4.5.0 package will have. If people upgrade to Maverick, they’ll still have your package.

    • My bad. I was a bit to hasty when naming the version. As you put it the problem would occur if/when the packages ported need to be updated to the real kdegraphic 4.5.0 final (or newer betas) even if it works as it should right now.

      I’ll correct the versioning soon.

  3. Why not use a rolling distro like Arch ? I can get updates within 24 hrs of the release of the next version. Also unlike Ubuntu the upgrades never break anything since its done in smaller increments continuously.

    • I don’t see why anyone would be interested in your remark.
      Anyway, you don’t know what you’re talking about..

  4. Now that SC 4.5 RC is out, do you know where can I get a updated digikam? The kubuntu beta ppa doesn’t include digikam or showfoto.

  5. It doesn’t work:

    QSqlDatabasePrivate::removeDatabase: connection ‘ConnectionTest’ is still in use, all queries will cease to work.
    Time elapsed: 14 ms
    Time elapsed: 2 ms
    Model: Time elapsed: 40 ms
    TextureColorizer: Time elapsed: 17 ms
    Time elapsed: 3 ms
    Time elapsed: 2 ms
    Model: Time elapsed: 7 ms
    digikam: symbol lookup error: /usr/lib/libdigikamcore.so.1: undefined symbol: _ZN11KDcrawIface19RawDecodingSettingsaSERKS0_

    any ideas how to fix it?

  6. Solve after a “sudo aptitude safe-upgrade” to upgrade
    libqtcore4 from version 4.6.2 to 4.6.3.

  7. Not working here. The mysql DB is tested to be ok but once you actually try to put something in it digikam complains that it’s lost connection and forever tries to reconnect. In sqlite it scans ok but there are no thumbnails.

    Methinks a severe lack of testing was done.

  8. My kubuntu installed on virtualbox doesn’t start anymore after I’ve installed it, any clue?

  9. Followed the instructions and now have a version of digikam that segfaults just after the “preparing collection scan” window closes and a new one pops up.

    Ran the aptitude safe-upgrade mentioned earlier. It wasn’t to upgrade libqtcore4 but other related packages like libkexiv2 and libkdcraw8.

    Seems to be working…

  10. In my case (ubuntu 10.04) it does not work. It does not start, complaining that

    >digikam: error while loading shared libraries: >libexiv2.so.9: cannot open shared object file: No such >file or directory

    In ubuntu 10.04 there is libexiv2-6 and the file /usr/lib/libexiv2.so.6 Many programs depend on it (kile, k3b …) and thus I cannot remove it.

    Should I install also libexiv2-9 (for instance the deb from debian testing)? Can it coexist with the version libexiv2-6?

    Thanks, gabriele

  11. I have upgraded to Lucid with KDE 4.5 using a clean installation. I cannot get digikam 1.4 or kipi 1.4 to compile.
    The issues relate to kde-graphics-data, and

    apt-get build-dep digikam gives:-

    The following packages have unmet dependencies.
    libkdcraw-dev: Depends: libkdcraw8 (= 4:4.5.0b-0ubuntu1~lucid1~ppa1) but 4:4.5.0+svn1136700-lucid~ppa1 is to be installed
    libkexiv2-dev: Depends: libkexiv2-8 (= 4:4.5.0b-0ubuntu1~lucid1~ppa1) but 4:4.5.0+svn1136700-lucid~ppa1 is to be installed
    E: Build-dependencies for digikam could not be satisfied.

    Nay thoughts on how to proceed here.

    Thanks,
    John

    • @Thorsten:

      from which ppa did you install KDE 4.5.1, I tried to install Digikam from nuovodna but have many unresolved dependencies:

      digikam:
      Hängt ab: libkabc4 (>=4:4.5.1) but it is not installable
      Hängt ab: libkdcraw8 (>=4:4.5.1), aber es wird 4:4.4.5-0ubuntu1~lucid1~ppa1 installiert
      Hängt ab: libkde3support4 (>=4:4.5.1) but it is not installable
      Hängt ab: libkdecore5 (>=4:4.5.1) but it is not installable
      Hängt ab: libkdeui5 (>=4:4.5.1) but it is not installable
      Hängt ab: libkexiv2-8 (>=4:4.5.1), aber es wird 4:4.4.5-0ubuntu1~lucid1~ppa1 installiert
      Hängt ab: libkfile4 (>=4:4.5.1) but it is not installable
      Hängt ab: libkhtml5 (>=4:4.5.1) but it is not installable
      Hängt ab: libkio5 (>=4:4.5.1) but it is not installable
      Hängt ab: libkipi7 (>=4:4.5.1), aber es wird 4:4.4.5-0ubuntu1~lucid1~ppa1 installiert
      Hängt ab: libkjsapi4 (>=4:4.5.1) but it is not installable
      Hängt ab: libknotifyconfig4 (>=4:4.5.1) but it is not installable
      Hängt ab: libkparts4 (>=4:4.5.1) but it is not installable
      Hängt ab: libkresources4 (>=4:4.5.1) but it is not installable
      Hängt ab: libkutils4 (>=4:4.5.1) but it is not installable
      Hängt ab: libmarblewidget10 (>=4:4.5.1) but it is not installable
      Hängt ab: libnepomuk4 (>=4:4.5.1) but it is not installable
      Hängt ab: libphonon4 (>=4:4.7.0really4.4.2), aber es wird 4:4.6.3-0ubuntu1 installiert
      Hängt ab: libqt4-dbus (>=4:4.7.0~rc1), aber es wird 4:4.6.3-0ubuntu1 installiert
      Hängt ab: libqt4-network (>=4:4.7.0~rc1), aber es wird 4:4.6.3-0ubuntu1 installiert
      Hängt ab: libqt4-qt3support (>=4:4.7.0~rc1), aber es wird 4:4.6.3-0ubuntu1 installiert
      Hängt ab: libqt4-sql (>=4:4.7.0~rc1), aber es wird 4:4.6.3-0ubuntu1 installiert
      Hängt ab: libqt4-svg (>=4:4.7.0~rc1), aber es wird 4:4.6.3-0ubuntu1 installiert
      Hängt ab: libqt4-xml (>=4:4.7.0~rc1), aber es wird 4:4.6.3-0ubuntu1 installiert
      Hängt ab: libqtcore4 (>=4:4.7.0~rc1), aber es wird 4:4.6.3-0ubuntu1 installiert
      Hängt ab: libqtgui4 (>=4:4.7.0~rc1), aber es wird 4:4.6.3-0ubuntu1 installiert
      Hängt ab: libsolid4 (>=4:4.5.1) but it is not installable
      Hängt ab: libsoprano4 (>=2.5.0+dfsg.1), aber es wird 2.4.2+dfsg.1-0ubuntu1.1 installiert
      Hängt ab: digikam-data, aber es wird nicht installiert

      • This is my /etc/apt/sources.conf.d:

        aleksander-m-dbus-development-lucid.list
        kubuntu-ppa-ppa-lucid.list
        kubuntu-ppa-backports-lucid.list
        nuovodna-nuovodna-stuff-lucid.list
        thilo.ginkel-qt4.7-bugfix-lucid.list

        (for add-apt-rerepository please use:
        ppa:aleksander-m/dbus-development
        ppa:kubuntu-ppa/ppa
        ppa:kubuntu-ppa/backports
        ppa:nuovodna/nuovodna-stuff
        ppa:thilo.ginkel/qt4.7-bugfix
        )

        The first one is a hint from dot.kde.org to fix dbus bugs triggered e.g. from dolphin

        The next two are my standard repositories for rolling kde upgrades in kubuntu

        Then the repository for digikam and last but not least a special qt bugfix repository for krdc and co. to fix fullscreen problems. Maybe these fixes are already backported to the standard repositories.

        HTH

        Thorsten

      • Thanks, I could install and start it now, but there are a couple of errors and no thumbnails show up, Digikam is completely empty:

        digikam(26751): couldn’t create slave: “Unable to create io-slave:
        klauncher said: Unknown protocol ‘digikamdates’.

        digikam(26751)/digikam (core) Digikam::AlbumManager::slotDatesJobResult: Failed to list dates
        digikam(26751): couldn’t create slave: “Unable to create io-slave:
        klauncher said: Unknown protocol ‘digikamalbums’.

        digikam(26751)/digikam (core) Digikam::ImageAlbumModel::slotResult: Failed to list url: “Could not start process Unable to create io-slave:
        klauncher said: Unknown protocol ‘digikamalbums’.
        .”
        digikam(26751)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType “KIPI/Plugin” not found
        digikam(26751)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType “Digikam/ImagePlugin” not found

  12. Hmm, looks like the dependencies are not complete. Lets try to do some checks:

    apt-file search digikamdates
    digikam: /usr/lib/kde4/kio_digikamdates.so
    digikam: /usr/share/kde4/services/digikamdates.protocol
    digikam-dbg: /usr/lib/debug/usr/lib/kde4/kio_digikamdates.so
    So, the kio-slave belongs to the digikam packages. As long as you do not have version mish-mash check if you fulfill all dependancies with

    ldd /usr/lib/kde4/kio_digikamdates.so

    You should get a loooong list with libraries you need to run this kioslave and you should not find any line talking about something “not found”

    If you miss e.g. libexiv2.so.6

    just type
    apt-file search libexiv2.so.6
    libexiv2-6: /usr/lib/libexiv2.so.6
    libexiv2-6: /usr/lib/libexiv2.so.6.0.0

    so, here you have to (re-)install libexiv2-6

    Was your 4.5.1 upgrade successful? No problemes when doing
    apt-get update && apt-get upgrade && apt-get dist-upgrade & apt-get -f install

    Bye

    Thorsten

  13. hmm, had one problem with some qt4_help something which was resolved after apt-get -f install.

    ldd /usr/lib/kde4/kio_digikamdates.so and
    ldd /usr/lib/kde4/kio_digikamalbums.so

    did not give any “not found”s or “missing”s… somewhere I read that the “Unable to create io-slave:” could have to do with not set env variables, but I do not know how to check/set these…

  14. Umhhhh…. forget what I just wrote, I did somehing I forgot about since I am not using Windows anymore… I did a reboot which fixed everything ;)

    Sorry and thank you for the Help!

  15. Hi, thanks for this. Does this method works for installing Digikam 1.6 on Ubuntu 10.10 ? I’m not able to find anywhere how to do it.

  16. crap. After the world’s longest install, the darn program crashes. ubuntu 10.04

  17. Hi,

    As you can read here and all over the internet, it simply does not work to install any higher version of Digikam than the 1.2 version in the 10.04 repo. I have tried every version from 1.3 on, and there always are missing dependencies.
    Digikam 1.2 on Kubuntu 10,04, however, always crashes on startup, as soon as you have added albums. So there is no working Digikam for 10.04 users.
    Suggestion: Could you open a ppa for 10.04 users with some working version of Digikam, higher than 1.2, including all the necessary dependencies. Thanks.

  18. This procedure only installs version 1.2.0 not the latest version which is 2.0.0

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s