Install the Latest Beta of digiKam on Ubuntu 10.10

If you are running Ubuntu 10.10 or its derivatives and you are itching to try the latest version of digiKam, you don’t have to go through the rigmarole of compiling the application yourself. Philip Johnsson did the hard work for you and released the neatly packaged version of digiKam on his PPA, so you can easily install the latest beta version of the next major release of digiKam with a minimum of fuss.

Before you proceed, remove the digiKam and Kipi plugins installed on your system. Fire up the terminal and add three repositories:

sudo apt-add-repository ppa:philip5/extra
sudo apt-add-repository ppa:philip5/kubuntu-backports
sudo apt-add-repository ppa:kubuntu-ppa/backports
sudo apt-get update

Use then the following command to install the latest beta version of digiKam:

sudo apt-get install digikam2 kipi-plugins2

That’s all there is to it. Of course, you should keep in mind that this is beta software, so the usual “use it at your own risk” disclaimer applies here.

Tech writer covering Linux and open source software

Tagged with: , ,
Posted in Open Source, Photography, Software
22 comments on “Install the Latest Beta of digiKam on Ubuntu 10.10
  1. plg says:

    Thank you for the tip. I’ve tested it and I confirm that “Export to Piwigo” works fine 🙂

  2. Sven says:

    For the opensuse readers: snapshot-packages of digikam have long been available at openSUSE’s buildservice in the KDE Playground repo and released versions in the UpdatedApps/Extra repo.

    You can either use the one-lick install at

    or add the repos manually e.g. for 11.3 and KDE 4.6 users:

    sudo zypper ar KDE46_Playground

    sudo zypper mr -r KDE46_Playground

    sudo zypper in digikam

  3. Good one..this will certainly save a lot of time…..i have compiled it last week….it took nearly 1 and half hours to compile and the downloading of some 250MB of packages..

  4. Fri13 says:

    If it would just be possible compile libkface(-git/-svn) library on arch linux to get digikam compiled….

    Impossible to test and work with upstream when that happens.

    • Philip Johnsson says:

      Why would that be? libkface doesn’t need that much of special stuff to get built. libqt >= 4.6.x, libkde >= 4.4.x and libopencv >= 2.0.0. That’s pretty modest compared to other stuff in the suit.

      • Fri13 says:

        Arch linux version of libkface gives the database.o errors at building. Impossible to get it build with current version. Were the system 32bit or 64bit.

  5. Stephen Thompson says:


  6. Useful. Have they fixed the problem where it wants to update a lot of your KDE with redone packages as well? Is this a one-way upgrade, ie. once you have done it it modifies your databases etc. and you can’t go back?

    • Philip Johnsson says:

      Digikam 2.0 need KDE 4.6.x to be built as it both use and develops frameworks for cutting edge KDE stuff, that’s dependecies you need even if you use KDE or not. You won’t see any “fix” from that. I don’t not know if you can go back to an older version of Digikam if you start saving stuff in your digikam database etc. A backup would anyway be the safe way as it’s still beta software.

      • Hi Phillip thanks for the packages, however im trying and testing Ubuntu 11.04, installed it abt 2 days back….couldnt find any packages for it….are there any packages for natty…or when will the PPA have packages for natty….Thank you very much…

  7. Tim Middleton says:

    Thanks very much, Philip. Ubuntu would be a much sadder place without you. (It is painfully tragic that the current Ubuntu release still has only digikam 1.4 in the official packages.)

  8. Dan Schuman says:


    I am a huge digikam fan and always very appreciative of the work you done on behalf of us fans but I am having trouble ever since the latest KDE updates starting coming down.

    When I try the above update, I get this:

    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package digikam2
    E: Unable to locate package kipi-plugins2

    Can anyone tell me how I fix this problem?

    Thank you

    • James Sellers says:


      I don’t have an answer, but I did have the same problem when I tried to install digikam2 last night. I thought it must be my lack of knowledge, but if other people are having the same issue, perhaps not.

      I would also love to have a fix for this.

      Many thanks.

      • James Sellers says:

        I discovered at the weekend that I was running Ubuntu 10.04. I have now installed 10.10, and digikam2 is successfully installed.

  9. Bob Kowalski says:

    Some information for Kubuntu Natty users: these packages will happily install & work perfectly with a minor tweak to the instructions given above. Follow the instructions as given above, but you must edit the repository entries: “natty” needs to be changed to “maverick” for the packages added.

    deb natty main

    needs to be changed to:

    deb maverick main

    and similarly for the other repositories.

    • Dan Schuman says:

      Thanks for the advice but the repositories are aready listed as maverick main any other suggestions?

    • Jonas Norlander says:

      I did try this before i saw this post but I was forced to remove it because of a couple of bugs.
      The worst was that I couldn’t add my NFS share with photos.

  10. Philip Johnsson says:

    Digikam 2.0 beta4 packages are now (at the time of writing) also available for 11.04/Natty and with Natty you only need the ppa:philip5/extra PPA.

    Happy digikaming!

  11. Concolor says:

    I used the method described in this post to install the latest version of digiKam on Ubuntu v10.10. It appeared to install correctly and I can run the program just fine. I imported several photos. They are in the database, but I can’t see any thumbnails in the album view. Any suggestions?

    Great software!

  12. After trying the install procedures got the following error:

    E: Couldn’t find package digikam2

  13. Michael Scholz says:

    Is that still working with Digikam 2.4 ? Do I have to use all 3 PPA´s running Maverick and just one PPA running Oneiric because upgrading my whole system only for Digikam ( albeit its a wonderful piece of software ) would be a bit “intense” …
    Im still running 2.04 and want to be on the “edge” of Digikam…

    cheers – Mike

Comments are closed.

Recipes for automated and streamlined photographic workflow on Linux

Use digiKam? Get this book!

Practical advice for nighttime photography

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

%d bloggers like this: