<!DOCTYPE html>
<!--[if !IE]>      <html class="no-js non-ie" lang="en"> <![endif]-->
<!--[if IE 7 ]>	   <html class="no-js ie7" lang="en"> <![endif]-->
<!--[if IE 8 ]>	   <html class="no-js ie8" lang="en"> <![endif]-->
<!--[if IE 9 ]>	   <html class="no-js ie9" lang="en"> <![endif]-->
<!--[if gt IE 9]><!--> <html class="no-js" lang="en"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<title>WD My Passport Wireless Linux Hacks | Scribbles and Snaps</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://scribblesandsnaps.com/xmlrpc.php" />

<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Lato:r:latin,latin-ext","Lato:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://s1.wp.com/wp-content/plugins/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">.wf-active .site-name{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}.wf-active body{font-family:"Lato",sans-serif}.wf-active h1, .wf-active h2, .wf-active h3, .wf-active h4, .wf-active h5, .wf-active h6, .wf-active .widget-title, .wf-active .widget-title-home h3{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}.wf-active blockquote p{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}.wf-active #featured h1.featured-title{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}.wf-active .top-widget .widget-title{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}@media screen and (max-width: 980px){.wf-active .featured-title{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}}@media screen and (max-width: 980px){.wf-active .featured-title{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}}@media screen and (max-width: 980px){.wf-active .featured-title{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}}</style>
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=scribblesandsnaps.com&amp;id=9736060&amp;t=1486746855&amp;back=https%3A%2F%2Fscribblesandsnaps.com%2F2017%2F02%2F10%2Fwd-my-passport-wireless-linux-hacks%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//scribblesandsnaps.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Scribbles and Snaps &raquo; Feed" href="https://scribblesandsnaps.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Scribbles and Snaps &raquo; Comments Feed" href="https://scribblesandsnaps.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Scribbles and Snaps &raquo; WD My Passport Wireless Linux&nbsp;Hacks Comments Feed" href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1473172720h&ver=4.6.1-RC1-38499"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJx9UtluAyEM/KFSGiWp8lL1Wwzrsk4AI8wm6t/XZHulBy8wY83gA9tLMZ5zw9xsWkyJS6AsNtIJxR6xFfAnc2X3XuTO/i2vGKHhZApL+8FGNs8VNZ4KtK5IOBFgxKSykS2Vxw9Xh7OWOExzKao2zpWKIkbPREsybdZEv31r2JbFaR9SOAud0Up7jbhqyWZupHL5BKPkAdlE9tCI8w0xLxGojqfqIgeFwarqGx2ZwPfHHdQvNJL3P1orsTJD7bne75FL2BNEbSXwLflvnPPOhsgO4vCfaAqo+9ObXbEJlSYDedIVlOtOPKenze6w328Pm+3D8Q0UUgfA' type='text/css' media='all' />
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyFj+sKwjAMhV/Irnib+kN8ll3izGzT2rQb7unNQBHnUAiEJF9OTnTvFVJlUg2sW4lbgnB/pqzlhf4FKItNKCJkFukFV44iUBxZ60o0oBJDKBrpidDZzXDecbTALNDM9NMSUofQ/8VaiL6orioA4/ClapPyJjVIrAMYeaBWo4dJNd2KFxCX2qdSOPaOGDsYT78rZV0NgXAIsnyyx+Umz7er9WG3bx9FIogr'></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://scribblesandsnaps.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Sonnenhut: a Script to Run before a Photo&nbsp;Walk' href='https://scribblesandsnaps.com/2017/02/03/sonnenhut-a-script-to-run-before-a-photo-walk/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/" />
<link rel='shortlink' href='http://wp.me/pEQNe-2eC' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=json&amp;url=https%3A%2F%2Fscribblesandsnaps.com%2F2017%2F02%2F10%2Fwd-my-passport-wireless-linux-hacks%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=xml&amp;url=https%3A%2F%2Fscribblesandsnaps.com%2F2017%2F02%2F10%2Fwd-my-passport-wireless-linux-hacks%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="WD My Passport Wireless Linux Hacks" />
<meta property="og:url" content="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/" />
<meta property="og:description" content="While WD My Passport Wireless is a rather useful device in its own right, the fact that it powered by a lightweight yet complete Linux distribution means that its capabilities can be extended even …" />
<meta property="article:published_time" content="2017-02-10T09:34:07+00:00" />
<meta property="article:modified_time" content="2017-02-10T09:34:07+00:00" />
<meta property="og:site_name" content="Scribbles and Snaps" />
<meta property="og:image" content="https://scribblesandsnaps.files.wordpress.com/2017/02/20170208-132155.jpeg?w=1200" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="900" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@dmpop" />
<meta name="twitter:image:src" content="https://scribblesandsnaps.files.wordpress.com/2017/02/20170208-132155.jpeg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@dmpop" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8c069cb996747c9890b816ac50b969a4?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8c069cb996747c9890b816ac50b969a4?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/8c069cb996747c9890b816ac50b969a4?s=114" />
<link rel='openid.server' href='https://scribblesandsnaps.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://scribblesandsnaps.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://scribblesandsnaps.com/osd.xml" title="Scribbles and Snaps" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="theme-color" content="#efefef" />
<meta name="application-name" content="Scribbles and Snaps" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Linux, Open Source, Photography" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://scribblesandsnaps.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/8c069cb996747c9890b816ac50b969a4?s=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="WD My Passport Wireless Linux&nbsp;Hacks | Scribbles and Snaps on WordPress.com" />
<meta name="description" content="While WD My Passport Wireless is a rather useful device in its own right, the fact that it powered by a lightweight yet complete Linux distribution means that its capabilities can be extended even further. Deploy, for example, rclone on the device, and you can back up the photos and raw files stored on the&hellip;" />
	<style type="text/css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px 1px 1px 1px); /* IE6, IE7 */
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<link rel="amphtml" href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s0.wp.com/?custom-css=1&#038;csblog=EQNe&#038;cscache=6&#038;csrev=58" />
		</head>

<body class="single single-post postid-8594 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">

<div id="container" class="hfeed">

	<div id="header">

		
	
		<div id="logo">
				<a href="https://scribblesandsnaps.com/" title="Scribbles and Snaps" rel="home">
				<img src="https://scribblesandsnaps.files.wordpress.com/2016/03/cropped-scribbles_and_snaps_v31.png" class="header-image" width="900" height="151" alt="" />
			</a>
							<span class="site-name site-title"><a href="https://scribblesandsnaps.com/" title="Scribbles and Snaps" rel="home">Scribbles and Snaps</a></span>
			<span class="site-description">Linux, Open Source, Photography</span>
		</div>

	
	
			<nav role="navigation" class="site-navigation main-navigation">
			<h1 class="assistive-text">Menu</h1>
			<div class="assistive-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>

			<div class="menu-navigation-container"><ul id="menu-navigation" class="menu"><li id="menu-item-5342" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5342"><a href="https://scribblesandsnaps.com/">Home</a></li>
<li id="menu-item-5343" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5343"><a href="https://scribblesandsnaps.com/linux-tools-for-serious-photographers/">Linux Tools For Serious Photographers</a></li>
<li id="menu-item-5344" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5344"><a href="https://scribblesandsnaps.com/books-projects/">Books and Projects</a>
<ul class="sub-menu">
	<li id="menu-item-5346" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5346"><a href="https://scribblesandsnaps.com/digikam-recipes/">digiKam Recipes</a></li>
	<li id="menu-item-7724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7724"><a target="_blank" href="https://gumroad.com/l/linux-photography">Linux Photography</a></li>
	<li id="menu-item-7725" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7725"><a target="_blank" href="https://gitlab.com/dmpop/little-backup-box">Little Backup Box</a></li>
	<li id="menu-item-5348" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5348"><a href="http://dmpop.github.io/mejiro/">Mejiro</a></li>
</ul>
</li>
</ul></div>		</nav><!-- .site-navigation .main-navigation -->
	
	
	</div><!-- end of #header -->

	<div id="wrapper" class="clearfix">
		<div id="content" class="grid col-620">


		
			<div class="breadcrumb-list"><a href="https://scribblesandsnaps.com/">Home</a> <span class="chevron">&#8250;</span> <a href="https://scribblesandsnaps.com/category/hardware/">Hardware</a> <span class="chevron">&#8250;</span> <span class="breadcrumb-current">WD My Passport Wireless Linux&nbsp;Hacks</span></div>
			<div id="post-8594" class="post-8594 post type-post status-publish format-standard has-post-thumbnail hentry category-hardware category-open-source category-software tag-backup tag-hacks tag-linux tag-rclone tag-wd-my-passport-wireless">
				<h1 class="post-title">WD My Passport Wireless Linux&nbsp;Hacks</h1>

				<div class="post-meta">
					<span class="meta-prep meta-prep-author posted">Posted on </span><a href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/" title="11:34" rel="bookmark"><span class="timestamp">2017/02/10</span></a><span class="byline"> by </span><span class="author vcard"><a class="url fn n" href="https://scribblesandsnaps.com/author/dmpop/" title="View all posts by Dmitri Popov">Dmitri Popov</a></span>
											<span class="comments-link">
							<span class="mdash">&mdash;</span>
							<a href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/#respond">Leave a comment</a>						</span>
									</div><!-- end of .post-meta -->

				<div class="post-entry">
					<p>While WD My Passport Wireless is a rather useful device in its own right, the fact that it powered by a lightweight yet complete Linux distribution means that its capabilities can be extended even further. Deploy, for example, <a href="http://rclone.org/" target="_blank">rclone</a> on the device, and you can back up the photos and raw files stored on the disk to any supported cloud storage service.</p>
<p>Before you can do this, though, you need to connect the device to a Wi-Fi network and enable SSH (so that you can access the underlying Linux system via SSH). To connect the WD My Passport Wireless to you current Wi-Fi network, power the device and connect to the wireless hotspot it creates from your regular Linux machine. Open a browser, point it to <em><a href="http://mypassport.local" rel="nofollow">http://mypassport.local</a></em>, and log in to the device&#8217;s web interface. Switch to the <strong>Wi-Fi</strong> section, and connect to the existing your local Wi-Fi network. Switch then to the <strong>Admin</strong> section and enable SSH access.</p>
<p><img data-attachment-id="8610" data-permalink="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/wd-mypassport-wireless-admin/" data-orig-file="https://scribblesandsnaps.files.wordpress.com/2017/02/wd-mypassport-wireless-admin.png?w=605" data-orig-size="979,840" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="wd-mypassport-wireless-admin" data-image-description="" data-medium-file="https://scribblesandsnaps.files.wordpress.com/2017/02/wd-mypassport-wireless-admin.png?w=605?w=500" data-large-file="https://scribblesandsnaps.files.wordpress.com/2017/02/wd-mypassport-wireless-admin.png?w=605?w=605" class="alignnone size-full wp-image-8610" src="https://scribblesandsnaps.files.wordpress.com/2017/02/wd-mypassport-wireless-admin.png?w=605" alt="wd-mypassport-wireless-admin" srcset="https://scribblesandsnaps.files.wordpress.com/2017/02/wd-mypassport-wireless-admin.png?w=605 605w, https://scribblesandsnaps.files.wordpress.com/2017/02/wd-mypassport-wireless-admin.png?w=150 150w, https://scribblesandsnaps.files.wordpress.com/2017/02/wd-mypassport-wireless-admin.png?w=500 500w, https://scribblesandsnaps.files.wordpress.com/2017/02/wd-mypassport-wireless-admin.png?w=768 768w, https://scribblesandsnaps.files.wordpress.com/2017/02/wd-mypassport-wireless-admin.png 979w" sizes="(max-width: 605px) 100vw, 605px"   /></p>
<p>On your Linux machine, open the terminal and connect to the device using the <code>ssh root@mypassport.local</code> command.</p>
<p>Deploying rclone then is a matter of running the following commands:</p>
<pre class="brush: bash; title: ; notranslate" title="">
curl -O http://downloads.rclone.org/rclone-current-linux-arm.zip
unzip rclone-current-linux-arm.zip
cd rclone-*-linux-arm
cp rclone /usr/sbin/
chown root:root /usr/sbin/rclone
chmod 755 /usr/sbin/rclone
mkdir -p /usr/local/share/man/man1
sudo cp rclone.1 /usr/local/share/man/man1/
sudo mandb
</pre>
<p>Once you&#8217;ve done that, run the <code>rclone config</code> command. Since you are configuring rclone on a headless machine, follow the instructions on the <a href="http://rclone.org/remote_setup/" target="_blank">Remote Setup</a> page. You&#8217;ll find detailed information on configuring and using rclone in the <a href="https://gumroad.com/l/linux-photography">Linux Photography</a> book.</p>
<p>You can put the WD My Passport Wireless to other practical uses, too. Since the device comes with Python, you can run scripts and Python-based web applications on the device. For example, you can deploy the simple <a href="https://github.com/dmpop/wimb">What&#8217;s in My Bag</a> application to track your photographic gear.</p>
<pre class="brush: bash; title: ; notranslate" title="">
curl -LOk https://github.com/dmpop/wimb/archive/master.zip
unzip master.zip
mv wimb-master/ wimb
cd wimb
curl -LOk https://github.com/bottlepy/bottle/raw/master/bottle.py
</pre>
<p>Run <code>./wimb.py</code> to start the app and point the browser to <em><a href="http://mypassport:8080/wimb" rel="nofollow">http://mypassport:8080/wimb</a></em> to access and use the application.</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-8594" class="share-google-plus-1 sd-button share-icon no-text" href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-8594" class="share-pinterest sd-button share-icon no-text" href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-8594" class="share-twitter sd-button share-icon no-text" href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/?share=email" target="_blank" title="Click to email"><span></span><span class="sharing-screen-reader-text">Click to email (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-9736060-8594-589df4e775799' data-src='//widgets.wp.com/likes/#blog_id=9736060&amp;post_id=8594&amp;origin=scribblesandsnaps.wordpress.com&amp;obj_id=9736060-8594-589df4e775799' data-name='like-post-frame-9736060-8594-589df4e775799'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>
					
						<div id="author-meta">
							<img alt='' src='https://1.gravatar.com/avatar/414614f7ac294749aea617c7331ae866?s=80&#038;d=retro&#038;r=G' class='avatar avatar-80' height='80' width='80' />							<div class="about-author">About <a href="https://scribblesandsnaps.com/author/dmpop/" title="Posts by Dmitri Popov" rel="author">Dmitri Popov</a></div>
							<p>Tech writer covering Linux and open source software</p>
						</div><!-- end of #author-meta -->

					
									</div><!-- end of .post-entry -->

				<div class="navigation">
					<div class="previous">&#8249; <a href="https://scribblesandsnaps.com/2017/02/03/sonnenhut-a-script-to-run-before-a-photo-walk/" rel="prev">Sonnenhut: a Script to Run before a Photo&nbsp;Walk</a></div>
					<div class="next"></div>
				</div><!-- end of .navigation -->

				<div class="post-data">
					Tagged with: <a href="https://scribblesandsnaps.com/tag/backup/" rel="tag">backup</a>, <a href="https://scribblesandsnaps.com/tag/hacks/" rel="tag">hacks</a>, <a href="https://scribblesandsnaps.com/tag/linux/" rel="tag">linux</a>, <a href="https://scribblesandsnaps.com/tag/rclone/" rel="tag">rclone</a>, <a href="https://scribblesandsnaps.com/tag/wd-my-passport-wireless/" rel="tag">wd my passport wireless</a><br />					Posted in <a href="https://scribblesandsnaps.com/category/hardware/" rel="category tag">Hardware</a>, <a href="https://scribblesandsnaps.com/category/software/open-source/" rel="category tag">Open Source</a>, <a href="https://scribblesandsnaps.com/category/software/" rel="category tag">Software</a>				</div><!-- end of .post-data -->

							</div><!-- end of #post-8594 -->

			


	
					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/02/10/wd-my-passport-wireless-linux-hacks/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="https://scribblesandsnaps.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
					<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="dea9bf0ddd" /><input type="hidden" name="_wp_http_referer" value="/2017/02/10/wd-my-passport-wireless-linux-hacks/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='8594' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7f9698084b" /></p>
<input type="hidden" name="genseq" value="1486746855" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="93"/></p>				</form>
					</div><!-- #respond -->
		<div style="clear: both"></div>
		
		

		</div><!-- end of #content -->


		<div id="widgets" class="grid col-300 fit">
		
			<div id="image-7" class="widget-wrapper widget_image"><div style="overflow:hidden;"><div style="width: 260px" class="wp-caption aligncenter"><a href="https://gumroad.com/l/linux-photography"><img src="https://scribblesandsnaps.files.wordpress.com/2016/07/linux-photography-6.jpg?w=250&amp;h=2500" title="Linux Photography" width="250" height="2500" /></a><p class="wp-caption-text">Recipes for automated and streamlined photographic workflow on Linux</p></div></div>
</div><div id="image-6" class="widget-wrapper widget_image"><div style="overflow:hidden;"><div style="width: 260px" class="wp-caption alignnone"><a href="https://gumroad.com/l/dailycurves"><img src="https://scribblesandsnaps.files.wordpress.com/2015/11/daily_curves_01.png?w=250&amp;h=532" title="Daily Curves set" width="250" height="532" /></a><p class="wp-caption-text">Curve presets for digiKam and the GIMP</p></div></div>
</div><div id="blog_subscription-2" class="widget-wrapper widget_blog_subscription"><div class="widget-title"><label for="subscribe-field">Email Subscription</label></div>
				<form action="https://subscribe.wordpress.com" method="post" accept-charset="utf-8" id="subscribe-blog">
											<p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
						<p><input type="text" name="email" style="width: 95%; padding: 1px 2px" placeholder="Enter your email address" value="" id="subscribe-field"/></p>
					
					<p>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="blog_id" value="9736060"/>
						<input type="hidden" name="source" value="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
						<input type="hidden" id="_wpnonce" name="_wpnonce" value="57046b1dbe" />						<input type="submit" value="Subscribe!" />
					</p>
				</form>
			
</div>		<div id="recent-posts-2" class="widget-wrapper widget_recent_entries">		<div class="widget-title">Recent articles</div>		<ul>
					<li>
				<a href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/">WD My Passport Wireless Linux&nbsp;Hacks</a>
							<span class="post-date">2017/02/10</span>
						</li>
					<li>
				<a href="https://scribblesandsnaps.com/2017/02/03/sonnenhut-a-script-to-run-before-a-photo-walk/">Sonnenhut: a Script to Run before a Photo&nbsp;Walk</a>
							<span class="post-date">2017/02/03</span>
						</li>
					<li>
				<a href="https://scribblesandsnaps.com/2017/01/31/repost-eiji-ohashi-roadside-lights-japan/">[REPOST] Eiji Ohashi, Roadside Lights&nbsp;(Japan)</a>
							<span class="post-date">2017/01/31</span>
						</li>
					<li>
				<a href="https://scribblesandsnaps.com/2017/01/24/repost-remarkable-photos-capture-the-light-that-plants-emit/">[REPOST] Remarkable Photos Capture the Light That Plants&nbsp;Emit</a>
							<span class="post-date">2017/01/24</span>
						</li>
					<li>
				<a href="https://scribblesandsnaps.com/2017/01/20/show-geotagged-photos-on-openstreetmap/">Show Geotagged Photos on&nbsp;OpenStreetMap</a>
							<span class="post-date">2017/01/20</span>
						</li>
				</ul>
		</div>		<div id="top-posts-3" class="widget-wrapper widget_top-posts"><div class="widget-title">Popular Articles &amp; Pages</div><ul class='widgets-list-layout no-grav'>
					<li>
												<a href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/" title="WD My Passport Wireless Linux Hacks" class="bump-view" data-bump-view="tp">
							<img src="https://i2.wp.com/scribblesandsnaps.files.wordpress.com/2017/02/20170208-132155.jpeg?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="WD My Passport Wireless Linux Hacks" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/" class="bump-view" data-bump-view="tp">
								WD My Passport Wireless Linux Hacks							</a>
						</div>
											</li>
									<li>
												<a href="https://scribblesandsnaps.com/linux-tools-for-serious-photographers/" title="Linux Tools For Serious Photographers" class="bump-view" data-bump-view="tp">
							<img src="https://i2.wp.com/scribblesandsnaps.files.wordpress.com/2012/08/piwigo1.png?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Linux Tools For Serious Photographers" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://scribblesandsnaps.com/linux-tools-for-serious-photographers/" class="bump-view" data-bump-view="tp">
								Linux Tools For Serious Photographers							</a>
						</div>
											</li>
									<li>
												<a href="https://scribblesandsnaps.com/2015/02/22/build-a-raspberry-pi-based-cable-shutter-release-for-sony-cameras/" title="Build a Raspberry Pi-Based Cable Shutter Release for Sony Cameras" class="bump-view" data-bump-view="tp">
							<img src="https://i0.wp.com/scribblesandsnaps.files.wordpress.com/2015/02/server_app3.png?resize=40%2C40&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Build a Raspberry Pi-Based Cable Shutter Release for Sony Cameras" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://scribblesandsnaps.com/2015/02/22/build-a-raspberry-pi-based-cable-shutter-release-for-sony-cameras/" class="bump-view" data-bump-view="tp">
								Build a Raspberry Pi-Based Cable Shutter Release for Sony Cameras							</a>
						</div>
											</li>
									<li>
												<a href="https://scribblesandsnaps.com/2011/03/13/manage-photos-from-multiple-digikam-installations/" title="Manage Photos from Multiple digiKam Installations" class="bump-view" data-bump-view="tp">
							<img src="https://secure.gravatar.com/blavatar/8c069cb996747c9890b816ac50b969a4?s=40" class='widgets-list-layout-blavatar' alt="Manage Photos from Multiple digiKam Installations" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://scribblesandsnaps.com/2011/03/13/manage-photos-from-multiple-digikam-installations/" class="bump-view" data-bump-view="tp">
								Manage Photos from Multiple digiKam Installations							</a>
						</div>
											</li>
									<li>
												<a href="https://scribblesandsnaps.com/2010/10/15/using-digikam-with-mysql/" title="Using digiKam with MySQL" class="bump-view" data-bump-view="tp">
							<img src="https://i1.wp.com/scribblesandsnaps.files.wordpress.com/2010/10/digikam_configuremysql.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Using digiKam with MySQL" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://scribblesandsnaps.com/2010/10/15/using-digikam-with-mysql/" class="bump-view" data-bump-view="tp">
								Using digiKam with MySQL							</a>
						</div>
											</li>
				</ul>
</div><div id="search-4" class="widget-wrapper widget_search"><div class="widget-title">Search</div>
	<form method="get" id="searchform" action="https://scribblesandsnaps.com/">
		<input type="text" class="field" name="s" id="s" placeholder="search here &hellip;" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Go"  />
	</form></div>
		</div><!-- end of #widgets -->
	</div><!-- end of #wrapper -->

</div><!-- end of #container -->

<div id="footer" class="clearfix">

	<div id="footer-wrapper">

		<div class="grid col-940">

		<div class="grid col-540">
				</div><!-- end of col-540 -->

		
		</div><!-- end of col-940 -->
		
	
		<div class="grid col-300 copyright">
			&copy; 2017 <a href="https://scribblesandsnaps.com/" title="Scribbles and Snaps">Scribbles and Snaps</a>
		</div><!-- end of .copyright -->

		<div class="grid col-300 scroll-top"><a href="#scroll-top" title="scroll to top">&uarr;</a></div>

		<div class="grid col-300 fit powered">
						<a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a>
			
					</div><!-- end .powered -->

	</div><!-- end #footer-wrapper -->

</div><!-- end #footer -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201706y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-414614f7ac294749aea617c7331ae866">
	</div>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/scribblesandsnaps.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/scribblesandsnaps.wordpress.com\/wp-login.php?action=logout&_wpnonce=27e3263524","homeURL":"https:\/\/scribblesandsnaps.com\/","postID":"8594","gravDefault":"retro","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"0","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="9736060" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://scribblesandsnaps.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="Scribbles and Snaps" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="191024c132" /><input type="hidden" name="_wp_http_referer" value="/2017/02/10/wd-my-passport-wireless-linux-hacks/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/scribblesandsnaps.com\/2017\/02\/10\/wd-my-passport-wireless-linux-hacks\/":8594};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
							<script type="text/javascript">
				jQuery(document).on('ready', function(){
					jQuery('body').on('click', 'a.share-pinterest', function(e){
						e.preventDefault();
						// Load Pinterest Bookmarklet code
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = window.location.protocol + "//assets.pinterest.com/js/pinmarklet.js?r=" + ( Math.random() * 99999999 );
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
						// Trigger Stats
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = this + ( this.toString().indexOf( '?' ) ? '&' : '?' ) + 'js_only=1';
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
					});
				});
			</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/02/10/wd-my-passport-wireless-linux-hacks/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			<div class="recaptcha" id="sharing_recaptcha"></div><input type="hidden" name="recaptcha_public_key" id="recaptcha_public_key" value="6LcYW8MSAAAAADBAuEH9yaPcF7lWh11Iq62ZKtoo" />
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/akismet-3.0/_inc/form.js?m=1404442431h'></script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJzTLy/QTc7PK0nNK9EvyClNz8wr1i+uzCtJrMjITM/IAeKS1CJMEWP94uSizIISoOIM5/yiVL2sYh19yo1yKioFEonFGUDz7HNtDU2MjIxNjAyNTbIA0Es/9Q=='></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://s0.wp.com/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://s0.wp.com/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeDefault.css?m=1363304414h&amp;ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ expand source';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Can\'t find brush for: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Brush wasn\'t configured for html-script option: ';
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.all();

// Infinite scroll support
jQuery( function( $ ) {
	$( document.body ).on( 'post-load', function() {
		SyntaxHighlighter.highlight();
	} );
} );
</script>
<link rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"9736060","siteName":"Scribbles and Snaps","siteURL":"https:\/\/scribblesandsnaps.com","icon":"<img alt='' src='https:\/\/secure.gravatar.com\/blavatar\/8c069cb996747c9890b816ac50b969a4?s=50&d=https%3A%2F%2Fs1.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/responsive","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/scribblesandsnaps.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fscribblesandsnaps.com%2F2017%2F02%2F10%2Fwd-my-passport-wireless-linux-hacks%2F","themeURL":"https:\/\/wordpress.com\/themes\/responsive\/","xhrURL":"https:\/\/scribblesandsnaps.com\/wp-admin\/admin-ajax.php","nonce":"28651d0993","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"57046b1dbe\" \/>","referer":"https:\/\/scribblesandsnaps.com\/2017\/02\/10\/wd-my-passport-wireless-linux-hacks\/","canFollow":"1","statusMessage":"","customizeLink":"https:\/\/scribblesandsnaps.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fscribblesandsnaps.wordpress.com%2F2017%2F02%2F10%2Fwd-my-passport-wireless-linux-hacks%2F","postID":"8594","shortlink":"http:\/\/wp.me\/pEQNe-2eC","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/scribblesandsnaps.com\/8594","statsLink":"https:\/\/wordpress.com\/stats\/post\/8594\/scribblesandsnaps.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Responsive","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in the Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 591 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/scribblesandsnaps.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fscribblesandsnaps.com%2F2017%2F02%2F10%2Fwd-my-passport-wireless-linux-hacks%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/scribblesandsnaps.com\/wp-admin\/admin-ajax.php","nonce":"7bee753551","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/scribblesandsnaps.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fscribblesandsnaps.com%2F2017%2F02%2F10%2Fwd-my-passport-wireless-linux-hacks%2F","blog_id":"9736060","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=9736060&v=wpcom&tz=2&user_id=0&subd=scribblesandsnaps","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyNUO1OwzAMfCFSC9FO/EE8S5aa1Vk+jJ107O2XSnSr0FTxy8757nwxXNi4nAqmAl5hxJkc8k/n9QU2o1gNh3qipBDojArfFStONo0BZSVTcqGObdiMXI6xCY0gh2sXKf11LBPGRuV6BEHlnJRmXJSPl1EnxEX/LdVoQzBtb93Jb8eWxhytQLRaUFpn8owitES/Y3sOrlBOi8O9e3YC5cevt7hvt5Prb+m2rCe7nJVcFQN4LGzd2azAjoazFvMVLAnoZIXSaa1N9Bk/Xvv3Yej7w9vgb+XewC0='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		<script>
			var _comscore = _comscore || [];
			_comscore.push({
				c1: "2",
				c2: "7518284"
			});
			(function() {
				var s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];
				s.defer = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<p class="robots-nocontent"><img src="https://sb.scorecardresearch.com/p?c1=2&c2=7518284&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" alt="" style="display:none;" width="1" height="1" /></p>
		</noscript><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'9736060','blog_tz':'2','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'9736060','v':'wpcom','tz':'2','user_id':'0','post':'8594','subd':'scribblesandsnaps'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGNrd29+Smw0TDhnZmRTK0hlRi9QSGh6bi9GXVhBJWIlZlR5c2RBRklGdXkrRV1LTmlnJjFsMDdVNUtGUWdfX3RUODV2cWh4JmksQzRhdm9GNS9JMktqWEV0S1IxMFRQQ0YxUDBUVCVBNUd6TmRvUV9qUCVxbit4TWlxRWsxJS90eSx1eXkrUUFJPWNWfFFJcEZJUl1qNzZRUVBzUVMxai83JS1VamFpc3hSM0k9KzkmQW11RmElYXhdb01lRkg/Znl4N0RCVjN5Sm9BMTZHeDBlZHg2Uy9NLk9Odj1tTHBpbkpmOC5QYVJhNVMsRVN2Sj96U2pmfHUuTktucG5HfExdSTJFL1hHbnZPNUZjOGxnY2x2N0pucUptbndbNlt3bWhrRlU9QXh3SFFRYWQ='}]);
_stq.push([ 'clickTrackerInit', '9736060', '8594' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>