<!DOCTYPE html>
<!--[if !IE]>      <html class="no-js non-ie" lang="en"> <![endif]-->
<!--[if IE 7 ]>	   <html class="no-js ie7" lang="en"> <![endif]-->
<!--[if IE 8 ]>	   <html class="no-js ie8" lang="en"> <![endif]-->
<!--[if IE 9 ]>	   <html class="no-js ie9" lang="en"> <![endif]-->
<!--[if gt IE 9]><!--> <html class="no-js" lang="en"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<title>Discover Photos from the Past with Natsukashii | Scribbles and Snaps</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://scribblesandsnaps.com/xmlrpc.php" />

<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Lato:r:latin,latin-ext","Lato:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://s0.wp.com/wp-content/plugins/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">.wf-active .site-name{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}.wf-active body{font-family:"Lato",sans-serif}.wf-active h1, .wf-active h2, .wf-active h3, .wf-active h4, .wf-active h5, .wf-active h6, .wf-active .widget-title, .wf-active .widget-title-home h3{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}.wf-active blockquote p{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}.wf-active #featured h1.featured-title{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}.wf-active .top-widget .widget-title{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}@media screen and (max-width: 980px){.wf-active .featured-title{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}}@media screen and (max-width: 980px){.wf-active .featured-title{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}}@media screen and (max-width: 980px){.wf-active .featured-title{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}}</style>
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=scribblesandsnaps.com&amp;id=9736060&amp;t=1532450267&amp;back=https%3A%2F%2Fscribblesandsnaps.com%2F2018%2F07%2F24%2Fdiscover-photos-from-the-past-with-natsukashii%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//scribblesandsnaps.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Scribbles and Snaps &raquo; Feed" href="https://scribblesandsnaps.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Scribbles and Snaps &raquo; Comments Feed" href="https://scribblesandsnaps.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Scribbles and Snaps &raquo; Discover Photos from the Past with&nbsp;Natsukashii Comments Feed" href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1532082729h&ver=4.9.8-beta1-43503"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJyNkd1SxCAMhV9IZKpbvXJ8FqCRZjcQhlB39u0F2x3tqow3kAPnIz/oc1KOY4FYdFhUosVjFH1OjoOSgASXG3XvRO707xjhCUQfoSTjTupT9ewZyBSYVGIpN6qHOc5Qz0MypTkCTGiAIFRbDwvp6Uq1cK4ldtOsXVubMoiougZcgipzTfSTW491WmztQxJHwXfQUi4E3Rw4eai9F07bFP6NCDs0pLBa9mKFUUcu6+U16L3qgRWxMwU57oR6I4O5/4uW2NfQ6+r6JnuQce1xa/JX1LO32ayVaJlNbrm2vUdtU6nl8F789X3zQXtia6gZXsPLMD6Mz8N4GB6PH3kMMRs=?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyFj+sKwjAMhV/IWgab4g/xWXaJM7VNa9NuuKc3A0WcQyEQknw5OdFjUEitzR2wNhK3DPH+TFvDG/0LUA77WCfYOqQX3HpKQGlmnW/QgsoMse6lJ0Jnv8IFz8kBs0Ar009LSAPC+BczkELdXlUExulL1WUVbO6RWEew8kCnZg+LarmVLiAudciNcBw8MQ4wn35XyvkOIuEUZfnkjkV5qIqqLPc78wBFGIgm'></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://scribblesandsnaps.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Photo Funnel: Easy Photo Import on&nbsp;Linux' href='https://scribblesandsnaps.com/2018/05/30/photo-funnel-easy-photo-import-on-linux/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/" />
<link rel='shortlink' href='https://wp.me/pEQNe-2oF' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fscribblesandsnaps.com%2F2018%2F07%2F24%2Fdiscover-photos-from-the-past-with-natsukashii%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fscribblesandsnaps.com%2F2018%2F07%2F24%2Fdiscover-photos-from-the-past-with-natsukashii%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Discover Photos from the Past with Natsukashii" />
<meta property="og:url" content="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/" />
<meta property="og:description" content="Since I left Facebook for good, I realized how much I liked a simple yet nice feature. Every day, Facebook would show me photos I took on this day a year ago. Although I wasn&#8217;t sharing a lot …" />
<meta property="article:published_time" content="2018-07-24T07:28:52+00:00" />
<meta property="article:modified_time" content="2018-07-24T07:28:52+00:00" />
<meta property="og:site_name" content="Scribbles and Snaps" />
<meta property="og:image" content="https://scribblesandsnaps.files.wordpress.com/2018/07/20180722-134602.jpeg" />
<meta property="og:image:width" content="605" />
<meta property="og:image:height" content="340" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:text:title" content="Discover Photos from the Past with&nbsp;Natsukashii" />
<meta name="twitter:image" content="https://scribblesandsnaps.files.wordpress.com/2018/07/20180722-134602.jpeg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@dmpop" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8c069cb996747c9890b816ac50b969a4?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8c069cb996747c9890b816ac50b969a4?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/8c069cb996747c9890b816ac50b969a4?s=114" />
<link rel='openid.server' href='https://scribblesandsnaps.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://scribblesandsnaps.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://scribblesandsnaps.com/osd.xml" title="Scribbles and Snaps" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="theme-color" content="#efefef" />
<meta name="application-name" content="Scribbles and Snaps" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Linux, Open Source, Photography" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://scribblesandsnaps.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/8c069cb996747c9890b816ac50b969a4?s=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="Since I left Facebook for good, I realized how much I liked a simple yet nice feature. Every day, Facebook would show me photos I took on this day a year ago. Although I wasn&#039;t sharing a lot of photos on Facebook, I enjoyed receiving these small greetings from the past. With Facebook banished from&hellip;" />
	<style type="text/css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px 1px 1px 1px); /* IE6, IE7 */
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<link rel="amphtml" href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s1.wp.com/?custom-css=1&#038;csblog=EQNe&#038;cscache=6&#038;csrev=58" />
		</head>

<body class="post-template-default single single-post postid-9217 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">

<div id="container" class="hfeed">

	<div id="header">

		
	
		<div id="logo">
				<a href="https://scribblesandsnaps.com/" title="Scribbles and Snaps" rel="home">
				<img src="https://scribblesandsnaps.files.wordpress.com/2016/03/cropped-scribbles_and_snaps_v31.png" class="header-image" width="900" height="151" alt="" />
			</a>
							<span class="site-name site-title"><a href="https://scribblesandsnaps.com/" title="Scribbles and Snaps" rel="home">Scribbles and Snaps</a></span>
			<span class="site-description">Linux, Open Source, Photography</span>
		</div>

	
	
			<nav role="navigation" class="site-navigation main-navigation">
			<h1 class="assistive-text">Menu</h1>
			<div class="assistive-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>

			<div class="menu-navigation-container"><ul id="menu-navigation" class="menu"><li id="menu-item-5342" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5342"><a href="https://scribblesandsnaps.com/">Home</a></li>
<li id="menu-item-5343" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5343"><a href="https://scribblesandsnaps.com/linux-tools-for-serious-photographers/">Linux Tools For Serious Photographers</a></li>
<li id="menu-item-5344" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5344"><a href="https://scribblesandsnaps.com/books-projects/">Books and Projects</a>
<ul class="sub-menu">
	<li id="menu-item-5346" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5346"><a href="https://scribblesandsnaps.com/digikam-recipes/">digiKam Recipes</a></li>
	<li id="menu-item-7724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7724"><a target="_blank" href="https://gumroad.com/l/linux-photography">Linux Photography</a></li>
	<li id="menu-item-7725" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7725"><a target="_blank" href="https://github.com/dmpop/little-backup-box">Little Backup Box</a></li>
	<li id="menu-item-5348" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5348"><a href="http://dmpop.github.io/mejiro/">Mejiro</a></li>
</ul>
</li>
</ul></div>		</nav><!-- .site-navigation .main-navigation -->
	
	
	</div><!-- end of #header -->

	<div id="wrapper" class="clearfix">
		<div id="content" class="grid col-620">


		
			<div class="breadcrumb-list"><a href="https://scribblesandsnaps.com/">Home</a> <span class="chevron">&#8250;</span> <a href="https://scribblesandsnaps.com/category/software/">Software</a> <span class="chevron">&#8250;</span> <a href="https://scribblesandsnaps.com/category/software/open-source/">Open Source</a> <span class="chevron">&#8250;</span> <span class="breadcrumb-current">Discover Photos from the Past with&nbsp;Natsukashii</span></div>
			<div id="post-9217" class="post-9217 post type-post status-publish format-standard has-post-thumbnail hentry category-open-source category-photography category-software tag-bash tag-shell-scripting">
				<h1 class="post-title">Discover Photos from the Past with&nbsp;Natsukashii</h1>

				<div class="post-meta">
					<span class="meta-prep meta-prep-author posted">Posted on </span><a href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/" title="09:28" rel="bookmark"><span class="timestamp">2018/07/24</span></a><span class="byline"> by </span><span class="author vcard"><a class="url fn n" href="https://scribblesandsnaps.com/author/dmpop/" title="View all posts by Dmitri Popov">Dmitri Popov</a></span>
											<span class="comments-link">
							<span class="mdash">&mdash;</span>
							<a href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/#respond">Leave a comment</a>						</span>
									</div><!-- end of .post-meta -->

				<div class="post-entry">
					<p>Since I left Facebook for good, I realized how much I liked a simple yet nice feature. Every day, Facebook would show me photos I took on this day a year ago. Although I wasn&#8217;t sharing a lot of photos on Facebook, I enjoyed receiving these small greetings from the past. With Facebook banished from my life, I decided to build an open source tool that does the same with my local photo library.</p>
<p><span id="more-9217"></span></p>
<p>I already had a rough script that sort of worked (&#8220;sort of&#8221; being the operative word), but it required some serious work to be of any practical use. So I spent a few days improving, enhancing, and optimizing the prototype. I named the project Natsukashii<sup>1</sup> and released it on <a href="https://gitlab.com/dmpop/natsukashii" target="_blank" rel="noopener">GitLab</a>.</p>
<p><img data-attachment-id="9218" data-permalink="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/natsukashii/" data-orig-file="https://scribblesandsnaps.files.wordpress.com/2018/07/natsukashii.png?w=412&#038;h=549" data-orig-size="1536,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="natsukashii" data-image-description="" data-medium-file="https://scribblesandsnaps.files.wordpress.com/2018/07/natsukashii.png?w=412&#038;h=549?w=375" data-large-file="https://scribblesandsnaps.files.wordpress.com/2018/07/natsukashii.png?w=412&#038;h=549?w=605" class="alignnone  wp-image-9218" src="https://scribblesandsnaps.files.wordpress.com/2018/07/natsukashii.png?w=412&#038;h=549" alt="natsukashii" width="412" height="549" srcset="https://scribblesandsnaps.files.wordpress.com/2018/07/natsukashii.png?w=412&amp;h=549 412w, https://scribblesandsnaps.files.wordpress.com/2018/07/natsukashii.png?w=824&amp;h=1098 824w, https://scribblesandsnaps.files.wordpress.com/2018/07/natsukashii.png?w=113&amp;h=150 113w, https://scribblesandsnaps.files.wordpress.com/2018/07/natsukashii.png?w=375&amp;h=500 375w, https://scribblesandsnaps.files.wordpress.com/2018/07/natsukashii.png?w=768&amp;h=1024 768w" sizes="(max-width: 412px) 100vw, 412px" /></p>
<p>Natsukashii consists of two parts: a Bash shell script that finds photos taken a year ago, and a simple PHP page that displays the results. The shell script relies on standard tools that are available on most mainstream Linux distributions (ImageMagick, ExifTool, sed, seq, and find). This means that you can deploy Natsukashii on practically any machine running a modern Linux distro. With a little bit of work, it is also possible to run Natsukashii on NAS appliances. In fact, I&#8217;m running the tool on my QNAP TS-231P NAS. The project&#8217;s README file provides brief instructions on installing and using Natsukashii, with detailed info available in the <a href="https://gumroad.com/l/linux-photography">Linux Photography</a> book.</p>
<p>While Natsukashii does the job, it isn&#8217;t particularly elegant and fast. The script goes through the specified directory and all its subdirectories looking for files with the given extension (e.g., <em>JPG</em>). For each found photo, the script extracts its creation date and compares it with the current date. Obviously, this takes time and resources. So if you have several thousand photos on your machine, running the script may take some time. So it might be a good idea to set up a cron job that runs the script during the night.</p>
<p><sup>1</sup>If you look up the word <em>Natsukashii</em> in a Japanese-English dictionary, you might find something like &#8220;dear,&#8221; &#8220;desired,&#8221; or &#8220;missed.&#8221; But that’s not really what it means; it&#8217;s just that there’s no way to directly translate it into English. Natsukashii is used to communicate a feeling of &#8220;Awww, I remember that! Those were such nice times, just thinking about it makes me feel so… natsukashii.&#8221; (source: <a href="http://www.justin-klein.com/natsukashii/">justin-klein.com/natsukashii</a>)</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/?share=reddit" rel="noopener noreferrer" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-9217" class="share-google-plus-1 sd-button share-icon no-text" href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/?share=google-plus-1" rel="noopener noreferrer" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-9217" class="share-pinterest sd-button share-icon no-text" href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/?share=pinterest" rel="noopener noreferrer" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-9217" class="share-twitter sd-button share-icon no-text" href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/?share=twitter" rel="noopener noreferrer" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/?share=email" rel="noopener noreferrer" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-9736060-9217-5b5755db24ce8' data-src='//widgets.wp.com/likes/index.html?ver=20180319#blog_id=9736060&amp;post_id=9217&amp;origin=scribblesandsnaps.wordpress.com&amp;obj_id=9736060-9217-5b5755db24ce8' data-name='like-post-frame-9736060-9217-5b5755db24ce8'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>
					
						<div id="author-meta">
							<img alt='' src='https://1.gravatar.com/avatar/414614f7ac294749aea617c7331ae866?s=80&#038;d=retro&#038;r=G' class='avatar avatar-80' height='80' width='80' />							<div class="about-author">About <a href="https://scribblesandsnaps.com/author/dmpop/" title="Posts by Dmitri Popov" rel="author">Dmitri Popov</a></div>
							<p>Tech writer covering Linux and open source software</p>
						</div><!-- end of #author-meta -->

					
									</div><!-- end of .post-entry -->

				<div class="navigation">
					<div class="previous">&#8249; <a href="https://scribblesandsnaps.com/2018/05/30/photo-funnel-easy-photo-import-on-linux/" rel="prev">Photo Funnel: Easy Photo Import on&nbsp;Linux</a></div>
					<div class="next"></div>
				</div><!-- end of .navigation -->

				<div class="post-data">
					Tagged with: <a href="https://scribblesandsnaps.com/tag/bash/" rel="tag">bash</a>, <a href="https://scribblesandsnaps.com/tag/shell-scripting/" rel="tag">shell-scripting</a><br />					Posted in <a href="https://scribblesandsnaps.com/category/software/open-source/" rel="category tag">Open Source</a>, <a href="https://scribblesandsnaps.com/category/photography/" rel="category tag">Photography</a>, <a href="https://scribblesandsnaps.com/category/software/" rel="category tag">Software</a>				</div><!-- end of .post-data -->

							</div><!-- end of #post-9217 -->

			


	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/07/24/discover-photos-from-the-past-with-natsukashii/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://scribblesandsnaps.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="3ff2bc7337" /><input type="hidden" name="_wp_http_referer" value="/2018/07/24/discover-photos-from-the-past-with-natsukashii/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google+ account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=retro&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
		w
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='9217' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d5b6381e6f" /></p>
<input type="hidden" name="genseq" value="1532450267" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="179"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
		
		

		</div><!-- end of #content -->


		<div id="widgets" class="grid col-300 fit">
		
			<div id="media_image-7" class="widget-wrapper widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><div style="width: 260px" class="wp-caption alignnone"><a href="https://gumroad.com/l/linux-photography" class="" rel="" target=""><img width="250" height="386" src="https://scribblesandsnaps.files.wordpress.com/2016/07/linux-photography-6.jpg?w=250" class="image wp-image-7733 aligncenter attachment-250x2500 size-250x2500" alt="" style="max-width: 100%; height: auto;" title="Linux Photography" srcset="https://scribblesandsnaps.files.wordpress.com/2016/07/linux-photography-6.jpg?w=250 250w, https://scribblesandsnaps.files.wordpress.com/2016/07/linux-photography-6.jpg?w=500 500w, https://scribblesandsnaps.files.wordpress.com/2016/07/linux-photography-6.jpg?w=97 97w, https://scribblesandsnaps.files.wordpress.com/2016/07/linux-photography-6.jpg?w=324 324w" sizes="(max-width: 250px) 100vw, 250px" data-attachment-id="7733" data-permalink="https://scribblesandsnaps.com/linux-photography-6/" data-orig-file="https://scribblesandsnaps.files.wordpress.com/2016/07/linux-photography-6.jpg" data-orig-size="1618,2500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="linux-photography-6" data-image-description="" data-medium-file="https://scribblesandsnaps.files.wordpress.com/2016/07/linux-photography-6.jpg?w=324" data-large-file="https://scribblesandsnaps.files.wordpress.com/2016/07/linux-photography-6.jpg?w=605" /></a><p class="wp-caption-text">Recipes for automated and streamlined photographic workflow on Linux</p></div></div><div id="media_image-6" class="widget-wrapper widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><div style="width: 260px" class="wp-caption alignnone"><a href="https://gum.co/tokyotaxi/" class="" rel="" target=""><img width="250" height="333" src="https://scribblesandsnaps.files.wordpress.com/2017/10/tokyo-taxi-lights-bookcover-3.jpg?w=250" class="image wp-image-9031 alignnone attachment-250x333 size-250x333" alt="" style="max-width: 100%; height: auto;" title="Tokyo Taxi Lights" srcset="https://scribblesandsnaps.files.wordpress.com/2017/10/tokyo-taxi-lights-bookcover-3.jpg?w=250 250w, https://scribblesandsnaps.files.wordpress.com/2017/10/tokyo-taxi-lights-bookcover-3.jpg?w=500 500w, https://scribblesandsnaps.files.wordpress.com/2017/10/tokyo-taxi-lights-bookcover-3.jpg?w=113 113w, https://scribblesandsnaps.files.wordpress.com/2017/10/tokyo-taxi-lights-bookcover-3.jpg?w=375 375w" sizes="(max-width: 250px) 100vw, 250px" data-attachment-id="9031" data-permalink="https://scribblesandsnaps.com/tokyo-taxi-lights-bookcover-3/" data-orig-file="https://scribblesandsnaps.files.wordpress.com/2017/10/tokyo-taxi-lights-bookcover-3.jpg" data-orig-size="1600,2133" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tokyo-taxi-lights-bookcover-3" data-image-description="" data-medium-file="https://scribblesandsnaps.files.wordpress.com/2017/10/tokyo-taxi-lights-bookcover-3.jpg?w=375" data-large-file="https://scribblesandsnaps.files.wordpress.com/2017/10/tokyo-taxi-lights-bookcover-3.jpg?w=605" /></a><p class="wp-caption-text">Practical advice for Tokyo night photography</p></div></div><div id="blog_subscription-2" class="widget-wrapper widget_blog_subscription"><div class="widget-title"><label for="subscribe-field">Email Subscription</label></div>
				<form action="https://subscribe.wordpress.com" method="post" accept-charset="utf-8" id="subscribe-blog">
											<p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
						<p><input type="text" name="email" style="width: 95%; padding: 1px 2px" placeholder="Enter your email address" value="" id="subscribe-field"/></p>
					
					<p>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="blog_id" value="9736060"/>
						<input type="hidden" name="source" value="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
						<input type="hidden" id="_wpnonce" name="_wpnonce" value="443ca48f94" />						<input type="submit" value="Subscribe!" />
					</p>
				</form>
			
</div>		<div id="recent-posts-2" class="widget-wrapper widget_recent_entries">		<div class="widget-title">Recent articles</div>		<ul>
											<li>
					<a href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/">Discover Photos from the Past with&nbsp;Natsukashii</a>
											<span class="post-date">2018/07/24</span>
									</li>
											<li>
					<a href="https://scribblesandsnaps.com/2018/05/30/photo-funnel-easy-photo-import-on-linux/">Photo Funnel: Easy Photo Import on&nbsp;Linux</a>
											<span class="post-date">2018/05/30</span>
									</li>
											<li>
					<a href="https://scribblesandsnaps.com/2018/05/18/build-a-simple-android-photo-app-with-jasonette/">Build a Simple Android Photo App with&nbsp;Jasonette</a>
											<span class="post-date">2018/05/18</span>
									</li>
											<li>
					<a href="https://scribblesandsnaps.com/2018/05/11/add-bash-shell-scripts-to-the-import-module-in-digikam/">Add Bash Shell Scripts to the Import Module in&nbsp;digiKam</a>
											<span class="post-date">2018/05/11</span>
									</li>
											<li>
					<a href="https://scribblesandsnaps.com/2018/04/03/big-update-for-little-backup-box/">Big Update for Little Backup&nbsp;Box</a>
											<span class="post-date">2018/04/03</span>
									</li>
					</ul>
		</div><div id="top-posts-3" class="widget-wrapper widget_top-posts"><div class="widget-title">Popular Articles &amp; Pages</div><ul class='widgets-list-layout no-grav'>
					<li>
												<a href="https://scribblesandsnaps.com/linux-tools-for-serious-photographers/" title="Linux Tools For Serious Photographers" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://scribblesandsnaps.files.wordpress.com/2012/08/piwigo1.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Linux Tools For Serious Photographers" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://scribblesandsnaps.com/linux-tools-for-serious-photographers/" class="bump-view" data-bump-view="tp">
								Linux Tools For Serious Photographers							</a>
						</div>
											</li>
									<li>
												<a href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/" title="Discover Photos from the Past with Natsukashii" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://scribblesandsnaps.files.wordpress.com/2018/07/20180722-134602.jpeg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Discover Photos from the Past with Natsukashii" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://scribblesandsnaps.com/2018/07/24/discover-photos-from-the-past-with-natsukashii/" class="bump-view" data-bump-view="tp">
								Discover Photos from the Past with Natsukashii							</a>
						</div>
											</li>
									<li>
												<a href="https://scribblesandsnaps.com/2018/01/29/digikam-recipes-18-01-25-released/" title="digiKam Recipes 18-01-25 Released" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://scribblesandsnaps.files.wordpress.com/2018/01/digikam-recipes-18-01-25.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="digiKam Recipes 18-01-25 Released" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://scribblesandsnaps.com/2018/01/29/digikam-recipes-18-01-25-released/" class="bump-view" data-bump-view="tp">
								digiKam Recipes 18-01-25 Released							</a>
						</div>
											</li>
									<li>
												<a href="https://scribblesandsnaps.com/2015/02/22/build-a-raspberry-pi-based-cable-shutter-release-for-sony-cameras/" title="Build a Raspberry Pi-Based Cable Shutter Release for Sony Cameras" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://scribblesandsnaps.files.wordpress.com/2015/02/server_app3.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Build a Raspberry Pi-Based Cable Shutter Release for Sony Cameras" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://scribblesandsnaps.com/2015/02/22/build-a-raspberry-pi-based-cable-shutter-release-for-sony-cameras/" class="bump-view" data-bump-view="tp">
								Build a Raspberry Pi-Based Cable Shutter Release for Sony Cameras							</a>
						</div>
											</li>
									<li>
												<a href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/" title="WD My Passport Wireless Linux Hacks" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://scribblesandsnaps.files.wordpress.com/2017/02/20170208-132155.jpeg?w=1200&#038;resize=40%2C40" class='widgets-list-layout-blavatar' alt="WD My Passport Wireless Linux Hacks" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://scribblesandsnaps.com/2017/02/10/wd-my-passport-wireless-linux-hacks/" class="bump-view" data-bump-view="tp">
								WD My Passport Wireless Linux Hacks							</a>
						</div>
											</li>
				</ul>
</div><div id="search-4" class="widget-wrapper widget_search"><div class="widget-title">Search</div>
	<form method="get" id="searchform" action="https://scribblesandsnaps.com/">
		<input type="text" class="field" name="s" id="s" placeholder="search here &hellip;" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Go"  />
	</form></div>
		</div><!-- end of #widgets -->
	</div><!-- end of #wrapper -->

</div><!-- end of #container -->

<div id="footer" class="clearfix">

	<div id="footer-wrapper">

		<div class="grid col-940">

		<div class="grid col-540">
				</div><!-- end of col-540 -->

		
		</div><!-- end of col-940 -->
		
	
		<div class="grid col-300 copyright">
			&copy; 2018 <a href="https://scribblesandsnaps.com/" title="Scribbles and Snaps">Scribbles and Snaps</a>
		</div><!-- end of .copyright -->

		<div class="grid col-300 scroll-top"><a href="#scroll-top" title="scroll to top">&uarr;</a></div>

		<div class="grid col-300 fit powered">
						<a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a>
			
					</div><!-- end .powered -->

	</div><!-- end #footer-wrapper -->

</div><!-- end #footer -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201830y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-414614f7ac294749aea617c7331ae866">
	</div>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/scribblesandsnaps.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/scribblesandsnaps.wordpress.com\/wp-login.php?action=logout&_wpnonce=5142bc4462","homeURL":"https:\/\/scribblesandsnaps.com\/","postID":"9217","gravDefault":"retro","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1521806916j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="9736060" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://scribblesandsnaps.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="Scribbles and Snaps" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="d61c83fbf4" /><input type="hidden" name="_wp_http_referer" value="/2018/07/24/discover-photos-from-the-past-with-natsukashii/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/scribblesandsnaps.com\/2018\/07\/24\/discover-photos-from-the-past-with-natsukashii\/":9217};
	</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2018/07/24/discover-photos-from-the-past-with-natsukashii/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<div
				class="g-recaptcha"
				data-sitekey="6LcmyE0UAAAAALID28yVNg7pFCodGaArJzHitez_"
				data-theme="light"
				data-type="image"
				data-tabindex="0"></div>
			<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en" async></script>
			
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1524699534h&cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"9736060","siteName":"Scribbles and Snaps","siteURL":"https:\/\/scribblesandsnaps.com","icon":"<img alt='' src='https:\/\/secure.gravatar.com\/blavatar\/8c069cb996747c9890b816ac50b969a4?s=50&d=https%3A%2F%2Fs2.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/responsive","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/scribblesandsnaps.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fscribblesandsnaps.com%2F2018%2F07%2F24%2Fdiscover-photos-from-the-past-with-natsukashii%2F","themeURL":"","xhrURL":"https:\/\/scribblesandsnaps.com\/wp-admin\/admin-ajax.php","nonce":"ca522de9d3","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"443ca48f94\" \/>","referer":"https:\/\/scribblesandsnaps.com\/2018\/07\/24\/discover-photos-from-the-past-with-natsukashii\/","canFollow":"1","feedID":"4120594","statusMessage":"","customizeLink":"https:\/\/scribblesandsnaps.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fscribblesandsnaps.wordpress.com%2F2018%2F07%2F24%2Fdiscover-photos-from-the-past-with-natsukashii%2F","postID":"9217","shortlink":"https:\/\/wp.me\/pEQNe-2oF","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/scribblesandsnaps.com\/9217","statsLink":"https:\/\/wordpress.com\/stats\/post\/9217\/scribblesandsnaps.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Responsive","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 646 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/scribblesandsnaps.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fscribblesandsnaps.com%2F2018%2F07%2F24%2Fdiscover-photos-from-the-past-with-natsukashii%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/scribblesandsnaps.com\/wp-admin\/admin-ajax.php","nonce":"59288f1692","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/scribblesandsnaps.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fscribblesandsnaps.com%2F2018%2F07%2F24%2Fdiscover-photos-from-the-past-with-natsukashii%2F","blog_id":"9736060","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=9736060&v=wpcom&tz=2&user_id=0&subd=scribblesandsnaps","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVUFlOw0AMvRATQ1GJ+EAcBU0nbuNkNuyZQG+PI5E2giqCL29vk+EjG5diwVhgEOhwIof5sxnkDlanUE329URRwNOIAu8VK/Y2dh55AVN0vnZ6VCGXQlCiYcz+3ASKPxVLj0GhuR6AUXKKQhPOzOtkxDHlIn+mSrDeG/WtG/ltp2nMwTIEKwVZO5MmZKY5+mX3T4XC1o2/kq5JrlCKM+nS3fqb5Our1vtBH87n79KsUTe8nOVUBT0MWLLmMstiK99IErCYx+Ye3tQZjonDBj4nKeboLTFIb5niaalKeg0vD/vdfte2T+3z8AWdTOVi'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20180319#ver=20180319' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'9736060','blog_tz':'2','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'9736060','v':'wpcom','tz':'2','user_id':'0','post':'9217','subd':'scribblesandsnaps'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGNrd29+Smw0TDhnZmRTK0hlRi9QSGh6bi9GXVhBJWIlZlR5c2RBRklGdXkrRV1LTmlnJjFsMDdVNUtGUWdfX3RUODV2cWh4JmksQzRhdm9GNS9JMktqWEV0S1IxMFRQQ0YxUDBUVCVBNUd6TmRvYX5QbkFLakIlK1ZVdTBOTERwQzJZMVJWVFtHZjU3X015anRfJjlQUThvVGUvXU1fRlRpTFYmVy4rTWZsODEyOV1JPURqUGN4UExNK1FuZUpLdyZ3TVpNdmtsRlY4UjhSMkFjSz0lQlREWWpLRHgtOFA3ai5BJWFqT3lnZS13YVRaZXw/Wk9BcUZXZDFlallJWkpicVJWdHJ3JXFdfmkyY2dVbkhmMWEzNTVXaUNpN05fJnZCQm1XLGI='}]);
_stq.push([ 'clickTrackerInit', '9736060', '9217' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
<!--
	generated 29 seconds ago
	generated in 0.105 seconds
	served from batcache in 0.001 seconds
	expires in 271 seconds
-->
